pi Dictate - Memory Training

Price: $0.99

Infomation

Category:
Education
By:
Terry Pundiak
Version:
5.00
Released:
2016-02-16
Shared:
2016-03-14
Size:
3.8 MB
Download:
400
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

No easier way to train for memorizing digits of pi - just speak as many digits as you want... Great for sharpening your skills! Train while walking or doing other activities that prevent directed keyboard input. Or like the other pi trainers, you can enter digits manually.

Pi Dictate is designed to allow you to work in batches - type or dictate a few digits or a dozens of digits at a time - by dictation or by typing. After dictation, you may edit your batch before entering them for final evaluation.

Pi Dictate gives you automatic speech feedback, telling you if your entry was correct and up to which decimal digit is successfully completed.

Errors, like typo's or mistakes, might be spotted and edited before submission - reducing frustration that occurs with typo's when you are trying for a new high score.

To help with training, you may press 'Hint' for a look ahead and you can press 'Jump Ahead' to skip to any position and train on deeper digit of Pi.

Memorizing Pi usually leads to greater memorizing skills and may lead you to seek and master a various mnemonic systems that greatly improve and ease the process, and yet have great utility for a variety memory activities.

...More

Video/Screenshots

What's New

Simplified and Improved interface.

...More Download the app
  • Download

  • Cracker/Uploader: telefonbuch
    Date: 2016-03-14 14:56 Version:5.00
    Memo:
  • Cracker/Uploader: telefonbuch
    Date: 2016-03-14 14:56 Version:5.00
    Memo:
  • Cracker/Uploader: telefonbuch
    Date: 2016-03-14 14:56 Version:5.00
    Memo:
  • All Version Links

Download the app

Infomation

Category:
Education
By:
Terry Pundiak
Version:
5.00
Released:
2016-02-16
Shared:
2016-03-14
Size:
3.8 MB
Download:
400
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.