Submarine — Fast and Powerful Client for Reddit

Price: $1.99

Infomation

Category:
Entertainment
By:
Julian Weiss
Version:
1.2
Released:
2017-01-05
Shared:
2017-01-05
Size:
9.1 MB
Download:
2780
Compatibility:
Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

Submarine is the most powerful and intuitive Reddit client ever made. Lurk, post, and surf to the wide reaches of Reddit with a fully-powered vessel at your fingertips.

Submarine combines the smooth elegance of iOS with the powerful stability of Reddit, built after years of brainstorming and good ideas. Our vision is one of meticulous simplicity, all in the name of the most flexible and fully-featured user experience.

Key Features:
- Lightning-fast post viewing with support for all content types
- Highly-customizable experience with several themes and endless configurations
- Support for all devices, multiple accounts, most moderator features, and anonymous lurking
- Minimal design with intuitive features and gestures
- Powerful, customizable tab bar which hides for fullscreen browsing
- Thorough subreddit and multireddit feature support
- Robust, unique navigation that helps you skip across all of Reddit

...More

Video/Screenshots

What's New

- Improve video playing and fix occasional issues with long-term usage
- Add full support for i.redd.it (reddit image hosting) links
- Removes NSFW switch (this must be edited on Reddit.com from here on out)
- Numerous bug fixes and improvements

Thanks for using Submarine! We're back for 2017 :)

...More Download the app
  • Download

  • Cracker/Uploader: Zachary/zachary
    Date: 2017-01-05 10:44 Version:1.2
    Memo:
  • Cracker/Uploader: Zachary/zachary
    Date: 2017-01-05 10:44 Version:1.2
    Memo:
  • Cracker/Uploader: Zachary/zachary
    Date: 2017-01-05 10:44 Version:1.2
    Memo:
  • All Version Links

Download the app

Infomation

Category:
Entertainment
By:
Julian Weiss
Version:
1.2
Released:
2017-01-05
Shared:
2017-01-05
Size:
9.1 MB
Download:
2780
Compatibility:
Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.