Yapo Video Player: Learn Foreign Language Easy With Your Favorite Movies and Series

Price: $0.99

Infomation

Category:
Education
By:
Eugene Krivosheyev
Version:
1.4
Released:
2015-12-06
Shared:
2015-12-06
Size:
46.5 MB
Download:
660
Compatibility:
Compatibility: Requires iOS 7.1 or later. Compatible with iPhone, iPad, and iPod touch.

Description

Innovation for learning foreign language! You should try it!
Yapo is a video player application that separates listening and reading. This technique leads to strong understanding of spoken language.
Yapo works ingeniously simple:
1. Watch your favorite movie or series focusing on listening and understanding
2. If you don't understand something just swipe left and last phrase will repeat with subtitles. Read this sentence and focus on lexicon and meaning.
3. If you need to switch subtitles from native to foreign just tap on subtitles
4. Continue to watch video without subtitles – they will gone away automatically

You can learn any language you want this way. So this is not classical learning approach but new way of leasure time. Perfect investment for price of couple coffee cups.

Yapo is an application not a service. This means that we have no our movies collection and this way we don't force you to watch what we love only. Just save to Yapo any video from your desktop or laptop with iTunes.
Supported video format: mkv with internal subtitles and avi with external subtitles.

...More

Video/Screenshots

What's New

- Added ability to upload files via Wi Fi

- Fixed errors
- Productivity increase

...More Download the app
  • Download

  • Cracker/Uploader: telefonbuch
    Date: 2015-12-06 9:11 Version:1.4
    Memo:
  • Cracker/Uploader: telefonbuch
    Date: 2015-12-06 9:11 Version:1.4
    Memo:
  • Cracker/Uploader: AppCakeBot
    Date: 2015-12-20 9:30 Version:1.4
    Memo:
  • All Version Links

Download the app

Infomation

Category:
Education
By:
Eugene Krivosheyev
Version:
1.4
Released:
2015-12-06
Shared:
2015-12-06
Size:
46.5 MB
Download:
660
Compatibility:
Compatibility: Requires iOS 7.1 or later. Compatible with iPhone, iPad, and iPod touch.