Sky Gamblers Races

Price: $2.99

Infomation

Category:
Games
By:
Edon Games SRL
Version:
1.0.3
Released:
2017-05-12
Shared:
2017-05-12
Size:
1.43 GB
Download:
1500
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

Take the challenge and build your reputation on the ULTIMATE WWII AIR RACE game!
Leave your mark by Winning Epic Races of rare intensity. Unique visuals, sound effects, and gyroscope controls enable for a full 360 degrees flight in 3D space that create an immersive game experience.

-The Plane collection of your dream
Take the plunge of a highly detailed WWII planes flying the fastest motor sport on earth! Unlock more than 90 plane variants, including iconic “Mustang, Tomahawk, Messerschmitt, Spitfire, MiG and A6M Zero”.

-Incredible fun
Compete in more than 100 unique races in different environments ranging from large canyons to heavily forested hills, high mountains, beaches, and valleys. Choose from five game modes Normal, Slow Down, Elimination, Timed Races and Death Races.

- Real-Time Racing
Compete against opponents from around the world or race against your friends in real-time challenges. If multiplayer is not your thing or if you want to practice offline, drop into any race to challenge the AI-Controlled version with adjustable difficulty.

- Customize and Upgrade
Customize your plane with a wide range of paint but this is only the start. You can get under the hood and tune your engine, firepower, shield and fine-tune your “steering”. View the action from a variety of camera angles.

Cross platform multiplayer between iOS, macOS, and tvOS.
Takes advantage of Metal, iCloud, GameCenter, Replay Kit and AirPlay.
Supports MFi controllers.
Localized in 10 languages.

...More Download the app

Video/Screenshots

What's New

Changed a few of the pictures for races + some other minor fixes

...More

Infomation

Category:
Games
By:
Edon Games SRL
Version:
1.0.3
Released:
2017-05-12
Shared:
2017-05-12
Size:
1.43 GB
Download:
1500
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.