The Ring.

Price: $2.99

Infomation

Category:
Games
By:
Tigran Mkhitaryan
Version:
1.5
Released:
2017-06-19
Shared:
2017-07-16
Size:
633 MB
Download:
600
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

What you see before you, is not an ordinary thriller app – this project contains attributes of psychological audio-visual pressure. All happens with you, in your very room, so we earnestly recommend DO NOT turn on this game while being in stressful or anxious state of mind. This is a new generation game, with new technologies yet not wide spread and aware to the mass users and new methods of fear anatomy.

This game is strongly not recommended to the users younger than 18y.o., people with psychological issues and pregnant women.

Developers are not responsible for the psychological and / or physical damage after use of this product. If you are not sure about your strengths, DO NOT DOWNLOAD THIS APPLICATION AND REMEMBER: THIS IS JUST A GAME!!!

...More Download the app

Video/Screenshots

What's New

In this build:
Minor bug fixes

The Ring.
What you see before you, is not an ordinary thriller app – this project contains attributes of psychological audio-visual pressure. All happens with you, in your very room, so we earnestly recommend DO NOT turn on this game while being in stressful or anxious state of mind. This is a new generation game, with new technologies yet not wide spread and aware to the mass users and new methods of fear anatomy.

This game is strongly not recommended to the users younger than 18y.o., people with psychological issues and pregnant women.

Developers are not responsible for the psychological and / or physical damage after use of this product. If you are not sure about your strengths, DO NOT DOWNLOAD THIS APPLICATION AND REMEMBER: THIS IS JUST A GAME!!!

...More

Infomation

Category:
Games
By:
Tigran Mkhitaryan
Version:
1.5
Released:
2017-06-19
Shared:
2017-07-16
Size:
633 MB
Download:
600
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.