Discovr - discover new music with songs, videos, mp3s, and radio

Price: $2.99

Infomation

Category:
Music
By:
Filter Squad Pty Ltd
Version:
3.3
Released:
2016-05-17
Shared:
2016-05-17
Size:
9.5 MB
Download:
43893
Compatibility:
Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

Important Notice about Discovr:

The Discovr app will be under maintenance from 30 May 2016, and the app will not work or be available during this maintenance period.

This maintenance is occurring so we can give the app a long-overdue overhaul and bring it up to date for iOS 9+, the latest Apple devices, and to improve the music data.

The release date of the new version has not yet been determined, but it is in progress right now.

You can find out more information here:
http://davidmckinney.com/discovr

Thanks for your patience while we improve Discovr. Back soon!

...More

Video/Screenshots

What's New

* This version will be under maintenance from 30 May and will not work during this time
* New version is coming soon.
* See http://davidmckinney.com/discovr for more information

...More Download the app
  • Download

  • Cracker/Uploader: telefonbuch
    Date: 2016-05-17 15:24 Version:3.3
    Memo:
  • Cracker/Uploader: telefonbuch
    Date: 2016-05-17 15:24 Version:3.3
    Memo:
  • Cracker/Uploader: telefonbuch
    Date: 2016-05-17 15:24 Version:3.3
    Memo:
  • Cracker/Uploader: Locophone-ICPDA
    Date: 2016-05-17 15:50 Version:3.3
    Memo:
  • Cracker/Uploader: Locophone-ICPDA
    Date: 2016-05-17 15:50 Version:3.3
    Memo:
  • Cracker/Uploader: Zachary/zachary
    Date: 2016-05-17 18:19 Version:3.3
    Memo:
  • Cracker/Uploader: Zachary/zachary
    Date: 2016-05-17 18:19 Version:3.3
    Memo:
  • Cracker/Uploader: Zachary/zachary
    Date: 2016-05-17 18:19 Version:3.3
    Memo:
  • All Version Links

Download the app

Infomation

Category:
Music
By:
Filter Squad Pty Ltd
Version:
3.3
Released:
2016-05-17
Shared:
2016-05-17
Size:
9.5 MB
Download:
43893
Compatibility:
Compatibility: Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.