WRC Shakedown Edition

Price: $3.99

Infomation

Category:
Games
By:
MILESTONE s.r.l.
Version:
1.0
Released:
2013-03-14
Shared:
2013-03-23
Size:
280 MB
Download:
4140
Compatibility:
Requirements: Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPod touch (3rd generation), iPod touch (4th generation), iPod touch (5th generation) and iPad. Requires iOS 4.0 or later. This app is optimized for iPhone 5.

Description

Prove your driving skill with the official game of the FIA ​​World Rally Championship!
Choose between WRC official cars and plunge into drifts and jumps facing every challange you find in the special stage.
Do you have what it takes to become a champion of WRC?

- WRC EXPERIENCE mode
- TIME ATTACK mode

OFFICIAL RALLIES
- Rally Sweden
- Neste Oil Rally Finland
- ADAC Rallye Deutschland
- Rallye de France-Alsace
- Wales Rally GB
- Acropolis Rally
- RallyRACC-Rally de Espana

60 different Challenges

14 Special Stages

5 types of Challenges
- DRIFT
- RALLY POINTS
- HIT BOWLING PINS
- DODGE CONES
- TIME RACE

14 official WRC crews

AUTO OFFICIAL WRC
- Citroën DS3 WRC
- Ford Fiesta RS WRC
- Mini John Cooper Works WRC
- Volkswagen Polo R WRC

EASY START, HARD TO STOP
Choose an official team, run, win and unlock other tracks and teams from the World Rally Championship

Addictive and fun: drift, accelerate and jump as the great champions of WRC!

...More Download the app

Video/Screenshots

  • Download

  • Cracker/Uploader: Pawnstar/SinfulWidow
    Date: 2013-03-23 13:17 Version:1.0
    Memo:
  • Cracker/Uploader: Pawnstar/SinfulWidow
    Date: 2013-03-23 13:17 Version:1.0
    Memo:
  • Cracker/Uploader: not_given/ICBot
    Date: 2013-04-07 5:28 Version:1.0
    Memo:
  • All Version Links

Infomation

Category:
Games
By:
MILESTONE s.r.l.
Version:
1.0
Released:
2013-03-14
Shared:
2013-03-23
Size:
280 MB
Download:
4140
Compatibility:
Requirements: Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPod touch (3rd generation), iPod touch (4th generation), iPod touch (5th generation) and iPad. Requires iOS 4.0 or later. This app is optimized for iPhone 5.