pd-FIT

Price: $19.99

Infomation

Category:
Health & Fitness
By:
Beneufit, Inc.
Version:
2.2
Released:
2016-08-01
Shared:
2016-08-02
Size:
6.3 MB
Download:
560
Compatibility:
Compatibility: Requires iOS 7.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

Beneufit’s pdFIT™ is a disease management solution for Parkinson’s patients. The goal of the program is to reduce symptoms, delay disease progression and improve quality of life by leveraging exercise. This is accomplished by prescribing specific exercise protocols designed for Parkinson’s disease patients and continuously monitoring patient health through a series of tests provided through the pdFIT™ app.

According to a 2014 study, the pdFIT™ has improved fitness levels levels and manual dexterity for Parkinson's disease patients. The results of the study can be found at the following URL.

http://beneufit.com/content/beneufits-parkinsons-disease-pilot-study-2014

The system requires Bluetooth Low Energy (4.0) heart rate monitor and cadence sensors which can be purchased at http://shop.beneufit.com/collections/frontpage/products/pdfit. These sensors track your activity while the mobile app coaches you through personalized exercise protocols designed to reduce Parkinson's disease symptoms and delay disease progression.

Track and share your workout activity from the Beneufit dashboard. Track your progress and motor control over time with our circleTap™ finger tapping test. The dashboard includes quick and easy access to every workout and finger tapping test you've ever done.

The pdFIT™ system currently works with Apple mobile devices with Bluetooth 4.0 technology (iPhone 4S and up iPad 3 and up, iPad mini, iPod Touch 5th gen.)

...More

Video/Screenshots

What's New

BLE sensor identification on pairing page.
Enhanced UI elements.
Improved dashboard access.

...More Download the app Download the app

Infomation

Category:
Health & Fitness
By:
Beneufit, Inc.
Version:
2.2
Released:
2016-08-01
Shared:
2016-08-02
Size:
6.3 MB
Download:
560
Compatibility:
Compatibility: Requires iOS 7.0 or later. Compatible with iPhone, iPad, and iPod touch.