Airport Madness World Edition

Price: $6.99

Infomation

Category:
Games
By:
Big Fat Simulations Inc.
Version:
1.64
Released:
2015-12-20
Shared:
2015-12-21
Size:
44.1 MB
Download:
6650
Compatibility:
Compatibility: Requires iOS 5.1.1 or later. Compatible with iPhone, iPad, and iPod touch.

Description

You are an air traffic controller, at various real-world airports. Strive to keep airplanes separated, while avoiding midair collisions.

***NEW AIRPORT ADDED!***
Airport Madness: World Edition now offers Amsterdam Schiphol Airport! There are now eleven airfields to chose from. The next addition will arrive in February 2016, bringing you Zurich airport. These updates are free to you, our terrific fans!

The sixth game in the Airport Madness series includes new features, such as assignable arrival and departure runways, different game modes, human pilot voices, and radar. We've added a player efficiency meter, to show controllers how well they are performing. Control traffic at London Heathrow, San Francisco, New York JFK, Honolulu, Vancouver, Las Vegas, Funchal Madeira, Barcelona, Dubai, Amsterdam, and Alaska.

Click on the aircraft to display their individual control panels. Provide takeoff clearances only when runways appear to be clear of other aircraft.

...More

Video/Screenshots

What's New

Resolved issue with Barcelona traffic jam after runway closures;
Fixed issue which prevented earning certain achievements;
Fixed issue with clouds not turning off correctly;
Fixed issue with Schiphol local high scores.

...More Download the app
  • Download

  • Cracker/Uploader: Locophone-ICPDA
    Date: 2015-12-21 14:51 Version:1.64
    Memo:
  • Cracker/Uploader: Locophone-ICPDA
    Date: 2015-12-21 14:51 Version:1.64
    Memo:
  • Cracker/Uploader: Locophone-ICPDA
    Date: 2015-12-21 14:51 Version:1.64
    Memo:
  • All Version Links

Download the app

Infomation

Category:
Games
By:
Big Fat Simulations Inc.
Version:
1.64
Released:
2015-12-20
Shared:
2015-12-21
Size:
44.1 MB
Download:
6650
Compatibility:
Compatibility: Requires iOS 5.1.1 or later. Compatible with iPhone, iPad, and iPod touch.