Am I Going Down? Fear of Flying App

Price: $2.99

Infomation

Category:
Travel
By:
Vanilla Pixel Ltd
Version:
2.7
Released:
2016-10-08
Shared:
2016-10-08
Size:
33.7 MB
Download:
3250
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.

Description

“Am I Going Down?” is a flight risk calculator designed to help those with a fear of flying. After entering your journey details, “Am I Going Down?” provides the likelihood of your flight doing down.

How safe is your next flight?

Crashes may make the headlines, but they’re incredibly rare, and when they do happen, seldom lead to injury. With those facts, there’s no need for nervous flyers to fall back on anything but cold hard numbers. “Am I Going Down?” will tell you how and why you have only a millions-to-one chance of crashing, allowing you to fight fear with information.

Next time you want to fly, don’t take sleeping pills or a soft toy - take the truth.


CNN
“New app "Am I Going Down?" uses aviation statistics to analyze the odds a flight will crash.”

Mashable
“A new iOS app that uses big data to help alleviate the fears of anxious travelers”

Daily Mail
"'Am I Going Down?' app uses real flight statistics to analyse flight safety."

Also featured in: The Economist, Huffington Post, Quartz, Bustle, Gizmodo, Business Insider, Daily Telegraph, Gadget Show, and many more!



Disclaimer: While "Am I Going Down" is based on published flight and crash statistics to give an indication of flight safety, the app is intended for entertainment purposes only. The odds presented are an estimate of historical risk and not a prediction of future performance.

If you have any questions please contact [email protected] or follow @vanillapixel on Twitter.

...More

Video/Screenshots

What's New

Updated for iOS10

...More Download the app Download the app

Infomation

Category:
Travel
By:
Vanilla Pixel Ltd
Version:
2.7
Released:
2016-10-08
Shared:
2016-10-08
Size:
33.7 MB
Download:
3250
Compatibility:
Compatibility: Requires iOS 8.0 or later. Compatible with iPhone, iPad, and iPod touch.